Quick Question!

Have you ever purchased from PartSelect.com before?

960873-1-S-GE-WH23X10020        -Drain Pump - 120V 60Hz
960873-1-S-GE-WH23X10020        -Drain Pump - 120V 60Hz 960873-2-S-GE-WH23X10020        -Drain Pump - 120V 60Hz 960873-3-S-GE-WH23X10020        -Drain Pump - 120V 60Hz http://www.partselect.com/Schematics/GE/00117836i02.gif

Drain Pump - 120V 60Hz

PartSelect Number PS960873

This pump helps expel water from the washing machine and is activated after the spin speed is maintained for a specific period of time.

This part works with the following brands: GE, Hotpoint & Kenmore.

This part fixes the following symptoms:

  • Will not drain.
  • Compare At

    $185.77
  • You Save

    $30.96
  • Your Price

    $154.81
In Stock
Order within the next 3 hrs and your part ships today!
Fast Shipping Get this part fast. Average delivery time via regular ground: 1.8 days.

Installation Instructions Provided by PartSelect customers like you.

Average Repair Rating: 4.1 / 5.0, 2 reviews What's this?
1-2 of 2
 

18 of 22 people found this instruction helpful

Parts Used:
  • Drain Pump - 120V 60Hz
Level of Difficulty: Really Easy
Time to do repair: 15 - 30 mins
Tools: Pliers, Screw drivers
Customer: Joseph from SAINT JOSEPH, MO

Washer would not drain

First I unplugged the washer. I removed the back of the washer and located the pump.I removed all the water from the pump, then I removed the hoses from the pump. I removed the wires from the pump and removed the two screws holding the pump in. I replaced the pump and reconnected everything. It works like new. The pump was the exact same thing ge sells but it cost a lot less.

Help other customers find the most helpful instructions.

Were these instructions helpful?

14 of 17 people found this instruction helpful

Parts Used:
  • Drain Pump - 120V 60Hz
Level of Difficulty: Easy
Time to do repair: 15 - 30 mins
Tools: Screw drivers
Customer: CHRIS from DICKSON, TN

The motor burnt out on the pump

Well replacing the pump went fine. I even did a trial run on a rinse and spin cycle and it worked great. Then i ran another cylce of clothes and walked away thinking all is well. Much to my surprise when I went to go through the utility room it was flooded. I did some inspecting and realised that I had put a hose on backwards. LOL. The good thing was that after I fixed the hose all worked well and haven't had any trouble since then. Your company was the cheapest price I found and the quickest delivery. Thank you so much for your help.
Sincerly,
Chris Lewis

Help other customers find the most helpful instructions.

Were these instructions helpful?

1-2 of 2