2019053-1-S-Whirlpool-215581-Agitator Shaft Spring
2019053-1-S-Whirlpool-215581-Agitator Shaft Spring 2019053-2-S-Whirlpool-215581-Agitator Shaft Spring 2019053-3-S-Whirlpool-215581-Agitator Shaft Spring

Agitator Shaft Spring

PartSelect Number PS2019053

This part works with the following brands: Whirlpool, Admiral, Estate, Inglis, Kenmore, KitchenAid, Roper, Maytag, Crosley, Jenn-Air, Hardwick, Magic Chef, Amana, Caloric & Glenwood.

  • Compare At

    $5.52
  • You Save

    $.92
  • Your Price

    $4.60
In Stock
Fast Shipping Get this part fast. Average delivery time via regular ground: 1.8 days.

Installation Instructions Provided by PartSelect customers like you.

Average Repair Rating: 2.8 / 5.0, 1 reviews What's this?
1-1 of 1
 

8 of 8 people found this instruction helpful

Parts Used

Level of DifficultyEasy

Time to do repair:1- 2 hours

ToolsNutdriver, Pliers, Screw drivers, Socket set

CustomerRichard from Alexander City AL

Agitator not woking

Unplugged power cord then disconnected the water supply and drain hose. Removed 2 screws and took the front panel off. Laid washer on it's side and posistioned the transmission with the cover facing upward. Removed the hex head screws then used a razor knife and a putty knife to remove the silicone sealant. Found that the agitator shaft spring had broken and fallen into the housing jamming the gears that's used in agitation. Removed the oil and all broken pieces of the spring. Installed new shaft spring, replaced the oil then applied sealant to the cover and screwed the cover back down. Let the washer stay in the same posistion for about 18 hours to let sealant dry completely. Then I sat the washer back on it's feet and removed 2 screws that holds the top lid in place. This allowed me access to the tub cover where the INJECTOR T is located. Installed the injector T along with the injector tube seal. Connected the hose and hose clamp. Then I put the lid back down and secured with the screws. Connected the water supply and drain hose then the power and selected a wash time and observed the operation. Everything worked ok so I put the front cover back on.
NOTE: I had used the injector T from this washer to fix another washer that an appliance dealer had given me to use for parts to repair the one just described above. That was the only thing that was wrong with it. It was used for about a year and a half and it developed a problem in the SPIN cycle. Appears to be a brake problem. I intend to repair it as well.

Help other customers find the most helpful instructions.

Were these instructions helpful?

1-1 of 1