LE Error Message and won't spin drum properly

ApplianceLGE Washer

ModelWM2077CW

Level of DifficultyEasy

Time to do repair30 - 60 mins

Age of Appliance5 - 10 years

Tools Screw drivers
Socket set

Mark From Harrisburg, PA

Jun 28, 2011

69 out of 85 people found this instruction helpful

I first tested the motor per the service manual. I checked the resistance between the terminals of the 3 pin connector. It's supposed to be 5-15 ohms. The motor checked out so I replaced the main electrical board. It turns out that wasn't the problem. After a brief web search I found out that the hall sensor (which is attached to the motor stator) was the likely cause of the failure. I replaced that and everything works great now. And now I have a spare main board in case that ever fails. I also want to mention that I took the time to remove the dispenser box (where the water comes in and is directed to the different cleaning products) and cleaned it with a very strong bleach solution. It got rid of the mildew and funky smell. It seems that the fabric softener caused a lot of mildew to form inside the dispenser directly above the fabric softener tray. The bleach took care of that. This is probably something that should be done routinely to keep the mildew from forming.

Help other customers find the most helpful instructions.

Were these instructions helpful?

Diagrams and Parts List for this repair

Part PhotoPart DescriptionPriceAvailability

SENSOR ASSEMBLY (Now subbed to Sensor Assembly)

Part Number: PS3529186

$20.11
In Stock